Email Delivery Delays
Incident Report for CareerPlug
Resolved
This incident has been resolved and all emails are being delivered!
Posted Feb 22, 2024 - 12:48 CST
Monitoring
The fix is currently in progress and we are monitoring the results.
Posted Feb 22, 2024 - 11:45 CST
Identified
We’ve identified an issue where some clients may encounter delays or failures receiving emails from CareerPlug. Particularly impacting delivery of emails such as Password Reset and Bulk Sharing Applicants from your CareerPlug account.

Our team is actively investigating the issue to restore normal service as quickly as possible.
Posted Feb 22, 2024 - 11:30 CST
This incident affected: CareerPlug.com.