Partial Visibility of Applicants on the Manage Applicants Page
Incident Report for CareerPlug
Resolved
This incident has been resolved. All applicants have been restored.
Posted Dec 07, 2023 - 15:04 CST
Investigating
We’ve identified an issue where some clients may not see all of their applicants on the Manage Applicants page: https://app.careerplug.com/manage/apps. No applicant data has been lost.

However, you will still be able to access applicants if you received an applicant notification email and click on the link to go to the applicant page in CareerPlug.

The fix is currently in progress and we're working on restoring all Applicants within 1 hour.
Posted Dec 07, 2023 - 14:16 CST
This incident affected: ATS (Applicant Tracking).