Delays in sending emails
Incident Report for CareerPlug
Resolved
Email sending has fully recovered.
Posted Jun 09, 2022 - 11:12 CDT
Identified
Email sending may be delayed for some customers. We’re investigating the issue and working to resolve it.
Posted Jun 09, 2022 - 10:59 CDT
Investigating
Email sending is currently delayed or unavailable for some customers. We’re investigating the issue and working to resolve it.
Posted Jun 09, 2022 - 09:43 CDT
This incident affected: CareerPlug.com.